Current restrictions, known problems and workarounds

Distance 5.0 Release 2


Last updated: 9 January December 2007

Current highest # : 349

Problems in GREY have been found and fixed.  Some of these fixes may be available in patches to the current release – see the Support page of the Distance web site for the latest patch and a list of problems fixed.

Current Restrictions

  • Project setup and import
    • If length or distance fields are measured in one field but to be analyzed in another then only the measurement units are imported from the old D3.5 file.  Units of analysis must be set in the new data filter manually.  (This is because data filters are not imported when the project is imported, and analysis units are now in the data filters.) If the units are not one of those that Distance recognizes (from the default project settings database) then the units will not be imported.
  • MCDS Analysis Engine
    • Maximum number of covariates and factor levels is listed in the manual, under “Limitations”
    • When covariates are specified, only half-normal and hazard-rate key functions allowed
    • Cannot force the fitted function to be monotonic decreasing
    • When cluster size is a covariate, stratified analyses are not allowed
    • Cannot have non-factor covariate value -9999. *  MRDS Analysis Engine - Line transect surveys only (not point transects) - Ignores units conversion specified in the Units tab of the Data Filter

Known Problems


  • 96 On many machines, you are asked to reboot during the install process.  However, on some Win98 machines, during reboot, you get the message “Cannot find setup.exe”.  Workarounds: 1. reboot again, or 2. Run d40setup.exe again. [Len: 13 March 01]
  • 179 On vanilla Win NT 4.0 SP6 machines (and possibly others), during the last part of the install, you get the error message “The procedure entry point _lc_collate_cp could not be loaded in the dynamic link library MSVCRT.dll”.  After installation is completed, you then cannot load geographic projects into D4 (e.g., the sample project D4Mexico).  Workaround: reboot, then install Distance 4 again.  [Len 10 May 2002 - cause new version of MSVCRT is installed, but is not backwards compatible – need to find some way to reboot before registering components if MSVCRT is replaced]
  • 246 On starting Distance on some machines get message “Distance could not find a component it needs to run. This is due to an installation problem or a conflict with another program.” or “Automation error. Library not registered.” or “File name or class name not found during automation operation.”  Usually occurs in D4Util.StringHandling module.  Solution:
    1. Uninstall Distance
    2. Download and install Windows Script 5.6 from Microsoft or the Distance web site
    3. Reboot
    4. Re-install Distance.
  • (Note: Windows Script 5.6 is supposed to be shipped with Windows XP but it may be that another program on this person’s system had broken it). [Colin Driscoll 24 Oct 03; Workaround LJT 27 Oct 03; other examples reported subsequently]
  • 255 Various problems have been reported on machines with some anti-virus software, including the machine locking up.  We recommend that you disable your anti-virus software while you run the setup program, and then enable it again after Distance is installed.  If you are concerned, feel free to scan the setup program for viruses before running it. [LJT 9 Dec 03]


Design properties items are in the next section, with the Design Engine

  • 16 General: Interface doesn’t prevent user from making changes while items are running – e.g., changing the Data Filter or Model Definition while an analysis is running.  If you do this, however, you will get errors.
  • 194 General: When upgrading from a Distance 3.5 project, and the destination folder for the D4 project is different from the source folder of the D35 project, under Windows 98 get an error that the new data file cannot be opened.  This error doesn’t occur under Windows XP. [Len 5 Aug 02]
  • 195 General – properties windows.  When you press F1, the help window that opens is always the same, regardless of which tab is showing.  Ideally, the help window would be appropriate for the tab.  [Len 12 Aug 02 – Cause: couldn’t get the Control Extender’s generic event to fire when late binding the properties controls – would like to have an event called HelpContextIDChanged that passes a new contextID each time a tab is shown in the properties controls.  Perhaps to do with binary compatibility?]
  • 247 General – Details windows.  On systems with extended character sets (e.g., Chinese, Japanese and Korean Language systems), the results of running analyses, surveys, etc. are not displayed.  This occurs because the results are compressed in the project database and the decompression doesn’t work on these systems.  Workaround: choose Tools Preferences, and under the General tab, un-check the box “Store results in compressed format in project databases”.  Now analyses you run should display fine.  Note that you will have to re-run previous analyses for them to display.  If you exchange projects with computers that do not have extended character systems, these computers will have to have the compress option switched off too.  [LJT 28 Nov 2003]
  • 19 Analysis Components: “No item selected” message sometimes pops up when you try to delete a Data Filter or Model Definition, even if you know that one is selected.  Workaround: Close the window and re-open it.  [Internal note: Caused by bug in grid component where the grid is not binding tightly enough to the data control, and the record gets out of synch.  Need to contact VideoSoft for fix or find a workaround.]
  • 21 Analysis Details, Results tab.  When the results page titles are very long, the drop-down combo list gets resized so it is wider than the screen, and so the scroll bar disappears. (Note: Problem is in D4Util.ComboAdjustWidth – need to use an API routine to get the left pixel position of the drop-down and subtract this from the screen width.)  [1 Dec 00]
  • 226 Analysis Details, Results tab.  When pasting a graph into another application that had been copied from CDS or MCDS results using “copy plot to clipboard”, one Windows ME system intermittently gave the error message “Distance has caused an error in MSCHRT20.ocx”.  Workarounds – (1) seems to be less common if you leave the graph page showing while doing the paste (ie don’t close the Analysis Details window); (2) save the plot data to file in Model Definition Detection function Diagnostics, and use the macro on the Distance web site from Tim Gerrodette to reproduce the plot in Excel.  Note – this is a problem with Microsoft’s chart control and we don’t expect to be able to fix it.  Related to known problems on the Microsoft web site support page numbers 139577, 142793 and 179458.  [Rob Williams 31 March 03].
  • 24 Browsers: Results pane (right hand side) – results with many 000s (either large or small) are not displaying in exponent format.
  • 26 Data Explorer: When you delete a data layer, any open design and survey details results windows that display maps go blank. [12 Jan 01]
  • 28 Data Explorer.  Some data editing functions missing: when you hit tab in data entry mode you are not taken to the next cell; the up and down arrow keys move you along the edit string rather than up and down.  Probably more issues here.
  • 29 Data Explorer: Operations that alter the structure of the data base (adding or deleting data layers, adding or deleting data fields, renaming fields or layers) cause an error if the data sheet is already locked by something else – for example if the layer is in a map that is open, or a design run.  [Len: I need to go through the data sheet code putting in LockDataLayers method calls, and also need to enforce no editing of data while items are running.]
  • 31 Data Explorer: When you add a new field to an existing data layer, the values are blank and have no default.  [I don’t know what’s a sensible thing to do here…]
  • 32 Data Explorer, Shape Properties.  When you input an invalid shape (e.g., only one vertex of a polygon) you get no warning message – the shape is simply not saved.
  • 133 Data Explorer - there is no way to delete cell values.  Pressing Del should turn the value into a Null - useful, for example, if you want to represent missing data in the data sheet (e.g., missing covariate values). [26 Sept 01, Len]
  • 138 Data Explorer, Data Import, etc.  Currently, there is no check that a field name is valid (e.g., in renaming fields, in importing new fields, etc). [1 Oct 01, Len]
  • 267 Data Explorer: When you rename a layer it should rename the shapefile [LJT 15 March 2004]
  • 332 Data Explorer: Allows you to delete the global record, with no warning at all! [EAR 26 September 2005]
  • 36 Data Filter Properties, Units tab.  When you specify units other than “Same as…”, you can get warning messages about overwriting the defaults when you run the analysis.
  • 129 Data Filter Properties, Units tab.  Angle is automatically specified as Degrees here, but unless you also specify some valid angle units in the Data Explorer, you get an error message when running the analysis: “The angle field ‘Angle’ has no units associated with it.”  This message is unclear - should say where you need to specify the units. [10 Sept 01, Len]
  • 37 Design Browser and Details: When you run a design to generate a coverage probability grid, if you say OK to overwrite an existing field, if it fails, it leaves the data layer in a poor state (the field name is deleted from DataFields but the field is still in the data table).
  • 38 Design Details: There is no “Stop” button once you press run. [12 Jan 01]
  • 39 Design Details: You can change the Type Of Design for designs that have been run, or that have Surveys attached to them, without Distance noticing and prompting you to agree to reset the Design and Surveys. [14 Jan 01]
  • 42 Details Windows: Too much refreshing and flickering of combo boxes when new items selected.  Particularly bad in Analysis Details.
  • 45 Details Log Windows: Clicking on an error in the bottom window doesn’t scroll you to that line in the top window.
  • 310 Help: On some systems, viewing some pages causes the following message to appear: “An ActiveX control on this page might be unsafe to interact with other parts of the page. Do you want to allow this interaction?”.  The problem is actually with the Microsoft HTML Help control, which is not installed properly for some reason.  One possible fix is to unregister and then re-register the control, which you can do by opening a Command Prompt window and typing the following two commands [Pierre Richard 28 Feb 2005; Workaround LJT 2 March 2005] :

    regsvr32 /u %windir%\\system32\\hhctrl.ocx
    regsvr32 %windir%\\system32\\hhctrl.ocx
  • 211 Import Data Wizard: “Error 3433: Invalid setting in Excel key of the Engines section of the Windows Registry” on some machines, when you click Next to go from the Data Destination step to the Data File Format step.  This is not a bug in Distance; another program on the affected system has changed a part of the windows registry to a state that isn’t valid.  The solution is to edit the windows registry to correct the problem.  To start the registry editor program, click Start and then Run.  In the Open box, type Regedit.exe.  In the registry editor, expand the following key: “HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Jet\3.5\Engines\Text”.  Under the Format key, you should see the following value: Delimited().  From the menu choose Edit and then Modify and change the value to CSVDelimited.  This should fix the problem.  If not, or the value was already CSVDelimited, then you have a different problem.  [DLB 14 Jan 03; Solution LJT 15 Jan 03]
  • 222 Import Data Wizard: Importing large datasets is very slow.  [20 March 03]
  • 331 Import Data Wizard: When you import into a dataset that has no global record, none of the imported records show up.  Proposed solution: when there is no global record, just add one before starting the import. [EAR 26 September 05]
  • 46 Main Window: If you stop a design simulation mid-way through (by pressing Stop on the toolbar), the progress % indicator on the main toolbar still says Progress x% - this should be cleared. Perhaps the design is not halted correctly or completely?  [12 Jan 01]
  • 47 Map Browser: Doesn’t allow you to hit enter in the name field in browser grids while editing.
  • 184 Map Window: If you use map tips, then when you try to close a project, get a message that it could not compact the project as DB still in use.  Possible reference leak in map tips?  Message goes away once you’ve exited Distance. [25 June 2002, LJT]
  • 49 Model Definition Properties: CDS and MCDS – Multipliers tabs.  If you select the CueRate box for any other than the first line in Multipliers, Distance will put them on the first line next time you open the properties
  • 125 Model Definition Properties: MCDS.  You can get to the position when it thinks cluster size has been added as a covariate when it hasn’t.  To get there: add a covariate, tick the cluster size box, then remove the covariate.  Clicking on the first tab, shows it thinks cluster size is a covar.  [LJT 19 July 2001]

Design Engine and Design Properties

  • 55 Design Engine cannot be run out of process (possibly some problem in the NEngineInterface) – gives a “cannot find stratum” error (by “run” I mean generate surveys and assess probability of coverage) [15 Jan 01]
  • 40 Design Properties: When you change the properties of a design that has already been run (ie coverage probability results exist), the status is not reset or results deleted [12 Jan 01]
  • 41 Design Properties: Pressing Defaults causes an object not found error.
  • 87 Design Properties: Problem with the calculator for probability of coverage when it is assumed even.  See – BajaCalifornia Norte has 87% of the effort, but looking at the results of the probability of coverage it is 0 for almost all the strata except the Sonora one (see Map and Grid1 field New Design). [9 Feb 01, Len]
  • 88 Design Properties: Zigzag design, maybe others.  Tick allocate effort by sampler length, update effort in real time, percentage from __ sampler length.  Now, as you enter values in the sampler length, you get error messages saying that the amount is not enough – I don’t think it should check as you actually change the number, but only when you loose focus from that box. [9 Feb 01, Len]
  • 89 Design Properties: Crash in design engine – subscript out of range.  See New Survey in  See also – may be the same problem, or a different one.  I think in this case it is something to do with the rotation of the design axis for each stratum – when I set them all to 0 it runs no problem. [9 Feb 01, Len]
  • 90 Design Properties: Equal spacing zigzag, Effort allocation, Design axis section.  The Defined as geographic coordinates tick box is enabled when you start by default.  If you click on the radio button Determined by start and end location, and then back on Runs at angle to design axis it is now disabled and I can’t seem to re-enable it.  [9 Feb 01, Len]
  • 263 Design properties: On some projected shapefiles, selecting options in the design coordinate system part of the General Properties tab causes an error in D4DesEng.GeneralDesignProperties.InitDesignObject when the project is run [Gjermund Bøthun 8 March 04]
  • 265 Design Properties: Systematic Random Line Design. Effort allocation, absolute values for line lengths.  When you enter a new line length value, the Samplers and Spacing columns don’t update. [LJT: 15 March 04]
  • 266 Design Properties: Systematic Random Line Design. Can define design axis by angle, but cannot define them by x-y coordinates as you can with the equal spacing zigzag.  Would be nice to add this feature.  [LJT: 15 March 04]
  • 91 I don’t know if the error messages in the survey for are valid nor not – 1,000,000 meters of sampling seems like it should be enough (see last bug for why its not in kilometers!). Looking at the data sheet, it does seem to have created 2 lines.  When I try 1,000,000 meters of effort per stratum, I get lines generated too, but also the same error messages in each stratum. [9 Feb 01, Len]
  • 92 Incorrect error messages about lines being too long and reset to 100000 in [9 Feb 01, Len]
  • 103 Sampler properties are not saved properly if you don’t choose same properties for all strata.  This can cause various error messages when running the design or survey, e.g.: (i) No effort, unable to generate survey; (ii) Error 13 (type mismatch) in D4DesEng. ControlDesignProcess. ReadDesignDefinitionString.  To reproduce: (i) Open mexico sample project; (ii) create a new design; (iii) on General Properties tab choose Stratum Layer: “MexStrat”; (iv) on Sampler tab, uncheck Same Properties for all strata; (v) click OK to save the sampler properties; (vi) open the properties again, and go to the Sampler tab – the properties for all the strata except the first one are now blank. [20 March 01, Len]
  • 120 If don’t define polygon for global stratum, then plots of surveys and designs at the region level have a strange extent [18 June 01, David] [Len to fix].
  • 121 Get an error message when you run designs with new layer names that include a “.” or “_”. [18 June 01, David] [Len to fix]
  • 122 Adjusted angle design sometimes plots both a straight line and a curved line for some sections of some transects (at least I’ve seen it do it on at least one transect quite frequently). See survey IJHalf2 (and IJHalf1) in [18 June 01, David]
  • 123 When using a design to create a new survey, the area and effort field names are not filled in (they are shown as [None] in the Survey Properties Data fields tab. (Internal note: the relevant commands are the Fld part of Area /Lyr= /Fld= and Effort /Lyr= /Fld=). [11 July 01, Len]
  • 274 Design engine: Equal angle zigzag.  Choosing a design axis angle other than 0 (e.g., 90) causes a subscript out of range error in the engine.  Defining the design axis using coordinates works.  [LJT 22 April 2004]
  • 275 Design engine?  Tools Preferences Design Echo commands to log works when you run the design to generate coverage prob, but not to generate a survey. [LJT 22 April 2004]
  • 276 Design Properties: Equal angle zigzag.  Setting effort to 0 (e.g., line length) in some strata causes a warning message, when it would be useful to be able to use to specify no effort in some strata.  Also, if you previously specified a positve line length, then the 0 value doesn’t seem to “take”, in that if you generate the survey there is a non-zero effort for that stratum [LJT 22 April 2004]
  • 289 When you specify assume even coverage under Coverage Probability and you have stratum, the coverage probabilities appear to be assigned to the wrong strata – see D4MexioTiago.dst [Tiago Marques 10 June 2004]

Analysis Engines (problems affecting >1 engine)

None at present

MCDS Analysis Engine (includes CDS as well)

  • 130 When running an analysis, if units are of the wrong type (e.g., angle field has units “meters”, then the resulting error message isn’t very helpful: “ Internal Error description: “Error reading project or program setting ‘AngUnit.Metre’: Setting not found, and no default supplied.” [10 Sept 01, Len]
  • 190 When you specify starting values or bounds on parameters, doesn’t check that the number of starting values does not exceed the number of parameters, and that the number of bounds does not exceed the total number of key functions.  (Note – see engine code commented out routine CheckBounds for more info). [LJT 17 July 02]
  • 227 On some machines (Windows 2000 and XP only) where the user has a name with accents in it, running any analysis produces the following error message:

    ** Warning: Analysis engine wrote some output to the console error
    stream, reproduced below. **
     -- Start of Console Error Stream -- 
     forrtl: severe (43): file name specification error, unit 13, file
    [there may be a file name or some jibberish here]
     Image              PC        Routine            Line        Source
     D4.exe             004B0039  Unknown            Unknown     Unknown
     [other lines here deleted]
     D4.exe             00431155  CLRDAT                    937  Datcom.for

The problem is that the FORTRAN analysis engine is not able to cope with TEMP directories that have accents in them.  The solution is to rename your TEMP and TMP environment variables.  Instructions for Windows XP (something similar should work in other operating systems): (i) Using Windows explorer, create a temp directory e.g., C:\Windows\Temp (or you may have one there already; you can use any other folder you like so long as it doesn’t have an accent in the folder name) (ii) From the control panel, open System Properties; (iii) In the Advanced tab, click on Environment variables; (iv) In the top window, look for the user variables TEMP and TMP. If they are there, change them both to c:\Windows\Temp (click the EDIT button). If they are not there, don’t worry; (v) In the bottom windows, look again for TEMP and TMP. If they are there, change them both to c:\Windows\temp. If they are not there, click on New to create them (one with variable name TEMP and value c:\Windows\Temp, then another with variable name TMP and value c:\Windows\temp); (vi) click OK to confirm the changes and then reboot to get the new environment variables loaded.  The analyses should now run without problems.  Contact us if it doesn’t. [LJT 14 April 2003; workaround 20 Oct 2003]

  • 326 CDS: Analytic confidence intervals from bootstrap density estimates can be very wide  – much wider than the corresponding percentile intervals.  Seems to be associated with some bootstrap replicates not converging. [Mark Faherty 27 July 2005]
  • 66 MCDS: Slow.  Generally needs some tuning of estimation. (Can vectorize arrays, etc.) [Aug 2000]
  • 162 MCDS: Bootstrap CV and confidence limit estimates do not include variance due to multipliers.  This means that the bootstrap results underestimate variance when multipliers with SEs>0 are specified. [9 Jan 02, LJT]
  • 198 MCDS: On Windows 2000, MCDS example detection function plots do not display properly – they show as two lines (red and blue) and no figure, rather than the expected 3 lines (yellow, orange, red) Solution: Install Windows Script 5.6, available for download from Microsoft or the Distance web site.  [18 Aug 02, LJT]
  • 344 When doing a size bias regression on data in intervals, the mcds engine uses the exact distance value that is in the data, rather than the interval.  [29 June 06 DLB] It now issues a warning to this effect, but all the same a better solution would be (a) when regressing cluster size against g(x) use the average g(x) between the interval cutpoints; (b) when regressing cluster size against x, use the estimated expected distance of an animal between the interval cutpoints.

MRDS Analysis Engine

  • 346 Units not recognized correctly at present (e.g., if you have line length in meters, distances in meters and area in ha you get an order of magnitude wrong answer).  Problem is likely in interface, not R library.  [LJT 17 Aug 2006]
  • 355 Cannot deal with missing distances in interval data.  Error is in function.  [Fixed LJT 9 Jan 2008 - fix implemented in D50 Release 2 patch 9 Jan 2008]
  • 356 When running analyses using previous detection functions, get error “Could not find the method command in model definition”.  [Fixed LJT 9 Jan 2008 - fix implemented in D50 Release 2 patch 9 Jan 2008]